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ATA e- Busmess Standards

Common Support Data Dictionary (CSDD)

ISpec 2200 - Information Standards for
Aviation Maint.

S1000D, International Specification for
Tech. Publications

Spec 1000BR - Civil Aviation S1000D
Business Rules

Spec 2000 - Provisioning (ch. 1)

Spec 2000 - Procurement Planning (ch. 2)

Spec 2000 - Materiel Management (ch. 3 — 4, 6)
Spec 2000 - Repair Order Administration (ch. 7)

Spec 2000 - Automated ID & Data Capture (ch.
9)

Spec 2000 - Reliability Data Collection and
Exch. (ch. 11)

Spec 2000 - Airline Inventory Redistribution

System (ch.12)

Spec 2000 - Industry Metrics (ch. 13)

Spec 2000 - Warranty Claims (ch. 14)

Spec 2000 - Aircraft Transfer Parts List (ch. 15)

Spec 2000 - Authorized Release Certificate (ch.
16)

Spec 2000 - Electronic Logbook (ch. 17)

Spec 2300 - Data Exchange Standard for Flight
Ops

Spec 2500 - Aircraft Transfer Records

Spec 42 - Aviation Industry Stds for Digital Info.
Security

World Airlines and Suppliers Guide (WASG)
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Organizational Structure

e-Business Steering Group

Spec 2000 ch. 2, 3,
4,6,8-2,10,12

Product Support
Mgt WG

2000 ch. 8, 13+1,
13-3 thru 18,7,
WASE




Typlcal ATA e- B|z Standard?

m Describes content for business information exchange
» Part numbers, dates, procedures, conditions, etc.

m Describes the “business rules” for a function
» Information that must always be provided
> Iinformation that must be provided if certain conditions exist
» Information that may be provided
» Uses CSDD to define fields to minimize misuse

m Describes the structure/ formats

> XML, flat file, CSV, Bar Codes, etc.

> Messages (PO), Large Files/Modules (Provisioning, IPC,
AMM, etc), ID data (bar-code, RFID, etc.)



XML helps us to separate the structure from the
content.

Separate the formatting from the content
Make the data application neutral

Allow additional format validation using parsers,
based on Schemas

Allows hierarchy / relationships to be better depicted
Easier to support from corporate databases



m The Specifications
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tandards

m Spec 2000 - Provisioning (ch. 1)

m Spec 2000 - Procurement Planning (ch. 2)
» Procurement database
» Quotation process, Inventory Quantity Inquiries

m Spec 2000 — Material Management (ch. 3, 4, 6)
» Purchase Order Placement & Response
» Purchase Order Exceptions
» Shipment Notices
> Invoicing

m Spec 2000 — Repair Order Administration (ch. 7)
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Spec 2000 Standards
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m Spec 2000 Auto ID & Data Capture (ch. 9)
> Bar Coded Shipping/Receiving Labels
> RFID on Parts
> Traceability

m Spec 2000 — Reliability Data Collection / Exch. (ch. 11)

Hours, Landings, Flight Data, Out of Service Data
Event/Interruption, Logbook Data
LRU Removals, Shop Findings, Piece Parts

>
>
>
» Scheduled Maintenance, SB/Mods, QPA



D

I’L ry = ":-p‘_lﬂ - 't. - -

Spec 2000 Standards

Spec 2000 Industry Metrics (ch. 13)

> Reliability, Component Repair, Warranty
» Produce Support, Technical Resolution, Parts Delivery

Spec 2000 — Warranty Claims (ch. 14)

Spec 2000 — Delivered Aircraft Transfer Parts (ch. 15)
Spec 2000 — Authorized Release Certificate (ch. 16)
Spec 2000 — Electronic Logbook (ch. 17)




Spec 2000 - Tagged/Formatted Data

Spec 2000 Receiving Label (data matrix)

Bl

ABC Distributor, 123 Main St.,
Miiam, FL, USA 31005

<ShipNoticeHeader>
<CIC>CNA</CIC>
<SPL>81205</SPL>
</ShipNoticeHeader>
<ShipNoticeDetails>
<CPO>BS56877</CPO>
<<PNR>HLT8100-13-91</PNR> "
<SHQ UNT="EA">10</SHQ>
<SHT>AMD</SHT>
<SHD>2004-09-30</SHD>
</ShipNoticeDetails>

Electronic Shipping Notice (XML)

Same Spec 2000 data
formats in Purchase Order,
Electronic Shipping Notice,
Shipping Label, RFID, etc.

Direct
Part
Mark

341/E01J123458

Spec 2000 Legacy EDI order
CAM

S1BOOKED/QE2/81205/USD/1/BNO 3/

((/HLT8100-13-1/1%EA/25.20/15077

MFR 81205*SER AB123
—> NR HLT8100-13-91

RFID

10



m Provides SGML Document Type Definitions (DTDS)
for 18 manuals including:

» Aircraft and Engine lllustrated Parts Catalogs (AIPC and
EIPC)

» Aircraft and Component Maintenance Manuals (AMM and
CMM)

Fault Reporting/Fault Isolation Manual (FRM/FIM)
Service Bulletin (SB)

Structural Repair Manual (SRM)

Wiring Manual (WM)

YV Vv V V¥V

= Home of the ATA Standard Numbering System
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Spec 230

m Industry standard for management,, and exchange of
digital flight operations technical data

s XML, Data Module Paradigm

m Covers data pertaining to:
> Flight Crew Operating and Training Data
» Cabin Crew Operating and Training Data
» Weight and Balance Data
» Minimum Equipment List / Dispatch / Deviation Data
» System Descriptions, Flight Phase Data

12



m Provides industry standard for:
» Authenticating the senders and receivers of digital data
> Verification if data has been altered
> Traceability of data to their source (non-repudiation)

m Based on Public Key Infrastructure (PKI)

m Includes Certificate Policies — describe the
comprehensive procedures and controls for
management of digital certificates and signatures:

> |dentity proofing and vetting
» PKI Key management
> Credential assurance level recommendations

13



S1000D

Collaborative effort between ATA e-Business, AlA,
ASD, bringing together defense and commercial
requirements.

Technical Data
XML based, data centric rather than document centric
Data centric rather than document centric

Civil Aviation’s requirements are represented by the
ATA e-Business Program through the CAWG

ATA e-Business Publishes a “Business Rules”
specification helping define implementation details

14



m Current or Recent Projects
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Spec 250

New industry standard exchange of Aircraft Transfer
Records. Published January, with revision 2 to be
published shortly

Based on ICAO/IATA/AWG requirements

Provides electronic “Crate” for metadata about data
and legacy documents.

Additional Status Reports are first data sets defined in
specification
» AD Status, SB/Mod/STC Status, Installed Component Status
> Aircraft/Engine Status, Repair/Damage Status
» Last Done/Next Due Maintenance Status

16
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Spec 240

m New specification describing Allowable Configuration
for aircraft/engine/major components in such a way as
to allow automated comparison with actual
configuration

m Planned publication this year

m Configuration Management Working Group also
focused on other CM use cases

17



Maintenance Execution Data Exchange

m New specification coming soon

m Describes the preparation and submittal of Work
Package / Work Order / Maintenance Task data from
operator to MRO Provider

m Describes return of maintenance accomplished
records from MRO to operator

m Allows for better system to system interfaces
m Facilitates fully digital maintenance



New Procurement Specification

New specification coming soon
Enhanced messages for the procurement process

Addresses business needs that the older
specification doesn’t handle well

Aligns with many newer M&E IT Systems



Data Harmonization

m Based on over 50 years of electronic data standards,
across varying new and legacy exchange formats
and technologies, there is a need to better
harmonize across the various specifications

m Goal is for more integrated, seamless data exchange
regardless of business function

m Continue to clarify and refine definitions

m Develop a data model and methodology to facilitate
more automated development of exchange
standards



m Example
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m A Use Case — XML for dual purpose
> Look at an XML Schema in Model View
> Look at the actual XML data

> Look at the same XML In html| format
transformed by a stylesheet

22
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attributes

Unnique identifier for the Crate,

ECm.iﬂeDaiit:Tlrm:
OrganizationInf

1.®

ATA_AircraftTransferRecordsCrate [7‘]—

Reot elem r top level Araaft

= ContentDateTime
CrateContent 4@—
—

ContentDetails
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Spec 2500 Excerpt

(MethodOfComplianceType E]—E)Ek

—| Compliancelnformation E]—Ejﬂ—

]
L
]

MOC

—ECompﬁameStatus

tion i the compliance item

ly open/closed)
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Sample XML

ATA _AircraftTransferRecordsCrate .....\Schemas\ATA_AircraftTransferRecordsCrate.xsd">
<CrateID source="Asset Management System">EX3</CratelID>
<CreateDateTime>2016-09-15T00:00:00Z</CreateDateTime>
<OrganizationInfo>
<OrganizationName>ABC Airlines</OrganizationName>
<OrganizationCode OrganizationCodeType="CAGE">12345</0OrganizationCode>
<OrganizationalRole>Lessee</OrganizationalRole>
<ContactName Role="Deliveries">
<Name>John Smith</Name>
<PostalAddress>
<AddressLine>ABC House</AddressLine>
<AddressLine>Gatwick Park</AddressLine>
<AddressLine>London Road</AddressLine>
<City>Crawley</City>
<Municipality>West Sussex</Municipality>
<State></State>
<PostalCode>RH10 9UY</PostalCode>
<Country>United Kingdom</Country>
</PostalAddress>
<Email>john.smith@aviation.com</Email>

<Phone>+441234123123</Phone>

</ContactName>..
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Sample XML

<MethodOfCompliances
<ComplianceInforma

<DatasetID sourtes Maintenance System":>ADS</DataSetID:
<TypedfDocument>EQ</TypedfDocument:
<CAGE_Code>9V238</CAGE_Code:
<Company=American Airlines</Company:
<Mode1>767-300</Mode1> I
</MaintenanceRecordiumber:
<Maintenancelescription>Replace the aft pressure bulkhead at Station 1582 of Section 48 wi
aftt pressure bulkhead, and perform all applicable related investigative and corrective actions, in accordance with the
Instructions of Boeing Alert Serwvice Bulletin 767-1B1234, Revision 1, dated August 4, 2816</Maintenanceblescripticonz
<firlineInternalTrackinglumber:>27-987876-33</AirlineInternalTrackingNumber:
<ComplianceTaskType>Part Replacement</ComplianceTaskType:
<SubstantiatingDalsked
<Substantigfinghataz

<CAG | Ref to Substantiating SB

<RevisionNum>13</RevisionNums
<RevisionDate>2016-88-14</RevisionDate:
</Substantiatingbatas
</SubstantiatingDatalist:>
<RepetitiveIndicatorstrue</Repetitivelndicators

</ComplianceInformations
{iimeﬁyclﬂnm Due before 60,000 Hours
<Threshold EarlierLaterdf="Later0f">
<TimeCyclelist:
<TimeCycleDetails>
<Date>2828-87-28Ta5

78 eaz< /Date>
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ame XML rendered in html

ATA Specl500 Content ATA AD Status

ATA AD Status Schema Version: 0

Regulatory | p,

Authority
AD Number | 2016-23-07
DatasetID / ! .
g AD1/ Asset Management System
AD Title Thiz AD was prompted by an evaluation by the design approval helder (DAH) mdicatimg that the aft pressure bulkhead at Station 1382 iz subject to widespread fatigue damage (WE
Effective
Date 2017-02-07
L] Airframe
Type
FAA
Amendment | 39-18733
Number
D s o
Related FAA 2004-03-16 AD2/ Aszet Management Svstem
S FAA 2004-14-19 4D3/ Asset Management System
FAA 2009-06-19 AD4 Asset Management System
— s o
S [FaA Ja00s0316 [ AD2A/AssetMemsgementSystem
AD

R ks Example of a paragraph-based AD

AD Status | Open
AMOC Flag | falze

Paragraph -

Reference 2016-25-07 PAR(G)
Paragraph
Status Open

Compliance -
Task Type oy

Bl Te detect and correct discrepancies m the aft attach lugs of the elevater tab control mechamsm group 1 a's
Description
Paragraph
Remarks

Note also requirement for paragraph H
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B Summary
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Some of |

m Legacy data is often available only on paper (or
scanned documents such as PDF).

m Slow, careful change due to regulatory environment
m “That's how we’ve always done it”

m Even when legacy systems are replaced by new
M&E systems, access to data isn’t always easy

m Data gquality, “cleanliness”

m Getting data from this system in our company to that
system in their company.
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Some Benefits of Standardization

Harmonization between different manufacturers,
operators, software providers allowing movement of
Important business data in common formats

Cost reduction — fewer manual processes
Improved information quality

Enhance digital security

Facilitate the use of digital maintenance tools
Enhanced record keeping

Help improve consistent understanding of data and
terms across enterprises

32



Rapid changing environments at the manufacturer,
operator, MRO and others —
the need to manage change

New systems / old systems — the need to integrate
More partners — the need to share

More information — the need to distill

Same old cost pressure - the need for reduced cost

33
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Join the ATA e-Business Program

m Program membership - $4000/company/year
m Unlimited number of employees may join and
participate

» Help guide industry decisions which may affect your
business

» See what changes are coming to the specifications

m Unlimited access to all ATA e-Business
specifications across the organization

34
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Contact us

D
ATA e-BUSINESS PROGRAM

1275 Pennsylvania Ave, NW
Washington, DC 20004
202-626-4039
admin@ataebiz.org

www.ataebiz.org
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